Project

General

Profile

Actions

Bug #408

closed

AI: cityresult_fill() assert failure when no known free tiles in city area

Added by Marko Lindqvist 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
AI
Target version:
Start date:
04/07/2024
Due date:
% Done:

0%

Estimated time:

Description

cityresult_fill() wants to count value for one another tile in addition to the city center. When it search for the best tile from the city area, unknown and already worked tiles are set to have a value of -1. If there is no other kind of tiles at all, that value of -1 gets used as the value of the best tile. This likely cause other bugs before, but in the end it can trip the assert in the end of the function making sure that total value is positive.


Files

Actions #1

Updated by Marko Lindqvist 3 months ago

The problem is not that such -1 tile gets used as the "best other", but that it gets counted to the "value of all remaining" tiles.

Actions #2

Updated by Marko Lindqvist 3 months ago

Actions #3

Updated by Marko Lindqvist 3 months ago

- Applies also to S2_6.

Actions #4

Updated by Marko Lindqvist 3 months ago

  • Status changed from In Review to Closed
Actions

Also available in: Atom PDF