Project

General

Profile

Actions

Bug #489

closed

S3_1 handle_investigate_started(): Dead assignment to unit_id32

Added by Marko Lindqvist 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
client-common
Target version:
Start date:
04/20/2024
Due date:
% Done:

0%

Estimated time:

Description

handle_investigate_started() does not use unit_id. In S3_1 we regardless assign a value to unit_id32.

This clang analyzer warning is a regression since 3.1.0 -> targeting to 3.1.1.


Files

Actions #1

Updated by Marko Lindqvist 3 months ago

S3_1 only.

Actions #2

Updated by Marko Lindqvist 3 months ago

  • Status changed from In Review to Closed
Actions

Also available in: Atom PDF